64x32 LED board won't show green top half of it! Help!

Using an RPI3A+, please help! I am willing to put a bounty on this at this point I just want this project done after troubleshooting this a month later. Top half of the LED board won’t show green, everything else works fine. I tried flipping the GPIO pins, still didn’t work. I switched 21 and 27, ended up getting a sound error (I’m not using sound on my board?). I will admit I am brand new to RPI, but I have a hunch its a pin problem… just not sure whats supposed to switch and not switch. Help!

you’re not saying which board you’re using, electrodragon, adafruit, direct wiring?
if you swap the wiring for red and green, do the green pixels light up?

I am using adafruit, and I did swap red and green but the red still lights up. Luckily I got a RPI4 so I’ll keep you updated to see if its a pi issue, because I saw on a adafruit forum someone else have the same issue and they switched RPIs and it worked for some reason

UPDATE: I solved it by swapping it for an RPI4 after reading on an adafruit forum and it solved all the problems. A word of advice to those in the future who have this exact problem: If you’re powering your bonnet through an RPI3A, SWAP IT OUT. Don’t waste your time troubleshooting, you’ll be wasting more time on that then waiting for the RPI shortage to go away.

Hope this helps someone :slight_smile: