Working on Pi3, gibberish on Pi4


I have a chain of 4x 128x64 1/32S panels connected to a Pi3 (Model A+ with 512 Mb) via an Electrodragon Hat.
When I run the -D0 demo everything works fine (altough there is a little flicker)

This is the command I’m using:
sudo ./examples-api-use/demo -D0 --led-cols=128 --led-rows=64 --led-slowdown-gpio=5 --led-chain=4 --led-parallel=1 --led-row-addr-type=3 --led-multiplexing=0

picture 1

When I take out the SD card and put it into a Pi4 (tried 2 Model B’s, one with 2Gb and one with 4Gb, with the same Electrodragon hat) and run the exact same command, the display is unrecognizable: dots and horizontal stripes are shown where the rotating square is supposed to be. (See picture 2).

Picture 2 command: same as picture 1 command

Changing slowdown-gpio slightly improves the displaying. With a value of 2 I can - sort of- distinguish the rotating square, however the image is still very very malformed with a lot of horizontal stripes in the neigboorhoud (see picture 3).

Picture 3 command (best result on Pi4):
sudo ./examples-api-use/demo -D0 --led-cols=128 --led-rows=64 --led-slowdown-gpio=5 --led-chain=4 --led-parallel=1 --led-row-addr-type=3 --led-multiplexing=0 --led-slowdown-gpio=2


I experimented with the various swithes like --led-pwm-lsb-nanoseconds, --led-no-hardware-pulse and --led-slowdown-gpio (tested from 1 up to 5) but I could not get the image as it is supposed to be.

Any suggestions on this would be greatly appreciated!

Caveat: I’m using an older version of this library via a forked project: GitHub - jenissimo/pico8-led: Run pico-8 and display it on the LED matrix

With that version of the library, for what it’s worth, my Pi 4B 4GB works fine using the following arguments: --led-rows=64 --led-cols=128 --led-chain=2 --led-slowdown-gpio=4 --led-brightness=80

I resolved any remaining minor flicker via tuning my PSU’s voltage dial.

One thought: What happens if you temporarily reduce the number of panels in your chain to 2? Does the behavior change at all?

see if the --led-slowdown-gpio=4 sorts it. =)