Dim displays on latest waveshare panels

Hi all, is anyone else experiencing this? I have 2 waveshare 64*32 P3 panels which work great. I use them with with both rpi-rgb-led-matrix and pixelpusher and LED Lab. I recently received 2 more and they are very dim when used in exactly the same setup. :frowning:

I noticed that the latest ones use a different chipset. The first pair that work well seem to be populated with a JXI JXI5020GP LED driver chip. The second pair that are dim use the superchip FM6047 LED driver. I’ve enquired with Waveshare and they are investigating, but no response so far so I thought I would ask here.

I am using an Adafruit bonnet modified for PWM to drive the boards from a Pi Zero 2 WH with a 50W high quality power supply. Same result without PWM. Same results with 1,2 or 4 boards.

Example command used is:

sudo /home/pi/rpi-rgb-led-matrix/examples-api-use/demo -D 4 --led-cols=64 --led-rows=32 --led-gpio-mapping=adafruit-hat-pwm --led-chain=4 --led-parallel=1 --led-pixel-mapper U-mapper --led-pwm-bits=11 --led-brightness=100 --led-show-refresh --led-limit-refresh=120

I have played with different settings for PWM bits, LSB… audio is off. And in all cases 2 of the boards are bright and the other 2 are dim.

The setup

The result

Brightness level 100 is not full brightness. I think the brightness range is 1-255.

note that brightness between panels with different chips, will not be the same and there isn’t much you can do about it except don’t mix and mach.
I have some FM2616A and FM2617 panels, and the brightness is not quite the same either.

Hey ,just fell over this and found a “official” solution look at
https://www.waveshare.com/wiki/RGB–Matrix-P3-64x32-Reginit

the Script is for one Panel only for more panels you need to modify the “MaxLED” Value before compiling.

absolutely, you can adjust or this in software if you are willing to do the work to do a brightness mapping in software and adjust the matrix values accordingly for each panel.
It’s just more work than I’m willing to do, so I make sure to have matching panels :slight_smile: