Artifacts with scrolling text

I’m running 3 daisy-chained 16x32 rgb matrices (adafruit) on a Raspberry Pi 4. Scrolling text is working well except for some artifacts in the pixels to the left of the characters. It’s not too bad with a single color r,g, or b but gets worse with multiple colors, especially white. To scroll the text I’m doing a os.system call to the scrolling-text-example with the following flags:

sudo ./scrolling-text-example --led-rows=16 --led-chain=3 --led-slowdown-gpio=2 -l 1 -s 5 -f <font path> -C <color>  <text>

EDIT: forgot to say I’m using the deprecated wiring scheme “classic-pi1” because I initially followed teh old Adafruit tutorial to wire it up, to be able to use that wiring I had to create a new mapping in /lib/hardware-mapping.c. So could my wiring potentially be the issue?
So I’ve tested different values for led-slowdown-gpio and 2 is the best one. This is a speech-to-text-to-translation application so I’m using a USB mic, Python SpeechRecognition library, and calls to google speech-to-text and translate-shell for text translation, so reading through the troubleshooting tips for this library I suspect the SpeechRecognition.listen() call could be causing the static output on the display.
Here are a couple video examples:
If anyone has tips on how to further troubleshoot I would appreciate input!

Further testing, nevermind the application I’m running it from, the artifacts continue to appear when I run scrolling-text-example straight from the command line, with a little bit on single colors and more with multiple colors. Here’s what I’m using in the function call:

sudo ./scrolling-text-example --led-rows=16 --led-chain=3 --led-slowdown-gpio=2 -s 5 -f ../fonts/9x15.bdf -C 255,255,255 "How's it going?"

I’m going to bite the bullet and try redoing the wiring with the “regular” mapping.

I rewired it according to the “regular” mapping with no change.

Did you tried to change power supply? It could also be caused by cables that are too thin

Thank you for the suggestion. The power supply is 5V, 2100mA, seems like it should be sufficient. I have made a change in the code that appears to have minimized the effect due to making threading processes more efficient. Not completely gone but I think will be acceptable.