64x64 black bands in display

sudo ./demo -D0 --led-gpio-mapping=regular --led-slowdown-gpio=4 --led-cols=64 --led-rows=64 --led-panel-type=FM6126A --led-multiplexing=1

Greetings! I’ve recently switched from 32x32 led matrix panels to a 64x64 matrix panel. I’ve been working around with settings but the closest I can get it to work is the image above. There are these black bands that don’t turn on. It’s not the LED multiplexing because that just jumbles the image more while keeping the black bands…

Any ideas on what I’m missing or what to try? Thanks very much for the help.

You had the exact same issue with the adafruit bonnet.
It was fixed by soldering two pads together
Check Driving Matrices | Adafruit RGB Matrix + Real Time Clock HAT for Raspberry Pi | Adafruit Learning System (step 3, second paragraph)

Thanks for the reply. I’m not using the Adafruit Bonnet or Hat though. I’m using a board that is based on HZeller’s design.

https://www.electrodragon.com/product/rgb-matrix-panel-drive-board-for-raspberry-pi-v2/

I do see on their wikipage that they mention “connect PIN4 or PIN8 to E_BUF for E-line” I wonder if that has to do with running 64x64 matrixes?

https://www.electrodragon.com/w/RPI_RMP_V2_HDK

64 is ABCDE, you need 5 address lines and you’re visibly missing one, the one that you need to solder on your board which is indeed E :slight_smile:

Thanks for the advice! I soldered the E line but still the same thing… what could be wrong?

did you solder it to the correct pin?

I have the same issue, except there are also some stripes in the black areas.

I will try the soldering and report backl.

BTW: this page describes what has to be done pretty well:

The HUB75 numbering is shown here:

that worked! I put some female headers on the board so I can select between the pin 4 and pin 8
version with dupont jumpers. My display was of the pin 8 variety.

cool, glad you got it working.

Hmmm… So strange… I still can’t get it working… I soldered header pins so I can test different configurations but the most I can do is reverse the part that’s on with the black stripes (so now the black strip area is turning ON). I can’t get the whole display to show at the same time… Is there anything that needs to be done with the code also?

The code does not care where the E pin is routed, it sends it to the same GPIO and the electrodragon board is responsible for sending that GPIO signal to the correct pin on the RGBPanel (via the jumper we discussed)

Hi have the same issua as jamesclar… could someone help me?

well, read all the messages and solution. Did you try it all?

Hi @marcmerlin, I’m seeing the same issue. I’ve checked the spec of the panel I’m using and it’s 4=GND, 8=E. I’ve jumpered the board (Electrodragon matrix V2) accordingly but still have the black band. Removing the 4->GND doesn’t seem to have any effect and removing the 8->E moves the image down a few rows. Any ideas what else I can try? Any help would be much appreciated, thanks.